Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Shared Mailboxes-Online Web Access Outage
Incident Report for GSU Technology Systems
Resolved
Service restored: Microsoft deployed a fix to the environment, users should now be able to access shared mailboxes via the web.

Please report any new related issues to IIT Technology Service Desk at help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP).
Posted Apr 26, 2024 - 08:41 EDT
Investigating
Scope of Impact
Users may be unable to access shared mailboxes from Outlook on the web. Users may receive a “Something Went Wrong repeated redirects” error message.

As a workaround users can access their shared mailboxes from the Outlook desktop client and Outlook mobile to avoid this issue.

https://gsutech.service-now.com/sp?id=kb_article&sys_id=01ca7369db389740186e5058dc961957&table=kb_knowledge

The issue is currently being investigated, and updates will be provided periodically on status.gsu.edu
Posted Apr 16, 2024 - 12:32 EDT
This incident affected: Office 365 (Fac/Staff Email).