Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Microsoft Office 365 Issues Reported

Incident Report for GSU Technology Systems

Resolved

This Microsoft Office 365 services and features incident has been resolved.

Please report any new incidents to help@gsu.edu, help.gsu.edu or call 404-413-4357(HELP) so that our teams may further investigate.
Posted Jun 12, 2023 - 14:02 EDT

Update

Microsoft has identified the problem with multiple Office 365 services and features and actively working on a solution.

Users reported slow and delayed access, blank screens and/or a 500 error when attempting to access Office 365 services and/or features.

Additional information will be posted here when the issue is confirmed.
Posted Jun 07, 2023 - 08:17 EDT

Update

Microsoft has identified the problem with multiple Office 365 services and features and actively working on a solution.

Users reported slow and delayed access, blank screens and/or a 500 error when attempting to access Office 365 services and/or features.

Additional information will be posted here when the issue is confirmed.
Posted Jun 06, 2023 - 15:09 EDT

Identified

Microsoft is currently investigating reports and identified with multiple Office 365 services and features. Users are reporting delayed access, blank screens and/or a 500 error when attempting to access Office 365 services and/or features.

Additional information will be posted here when the issue is confirmed.
Posted Jun 05, 2023 - 16:28 EDT

Monitoring

Microsoft has implemented a fix and the results are being monitored at this time.

Please report any new related incidents to help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP) so that our teams could further investigate the issue.
Posted Jun 05, 2023 - 12:33 EDT

Investigating

Microsoft is currently investigating reports with multiple Office 365 services and features. Users are reporting delayed access, blank screens and/or a 500 error when attempting to access Office 365 services and/or features.

Additional information will be posted here when the issue is confirmed.
Posted Jun 05, 2023 - 12:20 EDT
This incident affected: Office 365 (Fac/Staff Email) and Microsoft Office 365.