Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Power Outage: Alpharetta Campus

Incident Report for GSU Technology Systems

Monitoring

Power has been restored to the Alpharetta campus.

Please report any new incidents to IIT Technology Service Desk at help.gsu.edu, help@gsu.edu or 404-413-4357(HELP).
Posted Apr 23, 2025 - 17:26 EDT

Investigating

We are currently experiencing a utility power outage affecting Alpharetta AA and Alpharetta AB buildings.

Our Facilities and IT teams are actively monitoring the situation and are in contact with the utility provider to determine the cause and estimated restoration time.

Additional updates will be posted on here on status.gsu.edu as more information becomes available.
Posted Apr 23, 2025 - 13:27 EDT
This incident affects: Campus Network and Campus Wireless Network.