Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Global Microsoft Outage
Incident Report for GSU Technology Systems
Resolved
Final status: After an extended period of monitoring, in addition to internal validations and customer confirmations, we have declared the incident resolved.
Posted Jul 24, 2024 - 09:59 EDT
Monitoring
Final status: After an extended period of monitoring, in addition to internal validations and customer confirmations, we have declared the incident resolved.

We will continue to monitor reports over the next 24 hours.
Posted Jul 19, 2024 - 11:39 EDT
Identified
A global Microsoft outage has been reported and it that may affect any Microsoft related service and/or applications at this time.

More information will be posted on status.gsu.edu as additional information becomes available.
Posted Jul 19, 2024 - 08:07 EDT
This incident affected: Microsoft Office 365.