Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

GSU Sites Error

Incident Report for GSU Technology Systems

Resolved

This incitement has been resolved. If you continue to experiences issues access sites, please email help@gsu.edu or contact 404-413-4357 (HELP).
Posted Nov 19, 2025 - 09:56 EST

Monitoring

All GSU web services are currently operating normally, and we are no longer seeing elevated errors or latency with our infrastructure vendor. Our teams will continue monitoring the platform throughout the day and will continue to engage with our provider, though no additional system changes are being made at this time.

WordPress admins may now resume editing and updating GSU websites. We will continue to keep an eye on all tools and performance indicators for the remainder of the day.
Posted Nov 18, 2025 - 14:36 EST

Update

Our vendor continues to reduce system errors as they work through services globally and resolve remaining issues and latency. We encourage all WordPress admins to refrain from making updates until we confirm that all security and performance features are fully restored.

Full public access to our websites and web services — particularly on campus — was restored shortly before 10 a.m. EST. We will share additional updates as they become available.
Posted Nov 18, 2025 - 12:09 EST

Update

Our vendor continues to reduce system errors as they work through services globally and resolve remaining issues and latency. We encourage all WordPress admins to refrain from making updates until we confirm that all security and performance features are fully restored.

Full public access to our websites and web services — particularly on campus — was restored shortly before 10 a.m. EST. We will share additional updates as they become available
Posted Nov 18, 2025 - 12:01 EST

Identified

A fix has been implemented by our vendor, and they believe the incident is now resolved. This should provide public access to our websites and web services to all users. We are continuing to monitor for errors to ensure all services are back to normal as some administrative tools aren't fully accessible
Posted Nov 18, 2025 - 10:10 EST

Update

If you are unable to access icollege.gsu.edu please try to login using URL http://gastate.view.usg.edu/ as a potential workaround.
Posted Nov 18, 2025 - 09:15 EST

Investigating

Instructional Innovation and Technology (IIT) is aware there are possible intermittent issues related to one of our internet service vendors. We ask website administrators to refrain from trying to access and edit their websites while the vendor works to resolve remaining outages. We will continue to monitor the issue.
Posted Nov 18, 2025 - 08:37 EST
This incident affected: University Website.