Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Decatur Campus Network

Incident Report for GSU Technology Systems

Resolved

Network connectivity is now restored.
Posted Feb 12, 2026 - 21:03 EST

Investigating

The Decatur campus network is currently experiencing an outage. IIT is aware of the situation and is actively investigating the cause. We will provide updates as soon as further information becomes available.
Posted Feb 12, 2026 - 19:40 EST
This incident affected: Campus Network.