Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Telephone Disruption

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 08:45 EDT

Monitoring

A temporary workaround has been implemented to restore ten-digit dialing to GSUPD phone line (404-413-3333). IIT is continuing to work with the vendor to fully restore services including five-digit dialing to (3-3333)
Posted Apr 07, 2025 - 13:45 EDT

Investigating

IIT is currently investigating reports of phone line disruptions impacting the GSU Police Line 3-3333 (404-413-3333).

Individuals requiring assistance should contact 404-413-2100 until services are restored to 404-413-3333. In all emergency situations, 911 remains the designated emergency telephone number.

Our team is actively working to identify the issue and resolve it as quickly as possible. Updates will be provided as soon as they become available.
Posted Apr 05, 2025 - 11:53 EDT
This incident affected: Telephone System.