Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Power Outage: Decatur Campus
Incident Report for GSU Technology Systems
Resolved
Power has been restored to Decatur Campus.
Posted Mar 24, 2020 - 14:22 EDT
Identified
Instructional Innovation and Technology (IIT) received confirmation that power is disrupted on Decatur Campus. Ga Power shows an ETA for restoration at 11:00 a.m.
Posted Mar 24, 2020 - 10:00 EDT
This incident affected: Campus Network.