Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Power outage at Atlanta campus and TOC
Incident Report for GSU Technology Systems
Resolved
Power has been restored to the Atlanta campus. If you continue to experience issues or have questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 (HELP), email help@gsu.edu, or utilize self-service at help.gsu.edu.
Posted Oct 21, 2019 - 09:28 EDT
Monitoring
Power has been restored to the Atlanta campus. We will continue to monitor the status overnight and provide additional updates if the situation changes.
Posted Oct 20, 2019 - 17:56 EDT
Update
We continue to monitor the power disruption on the Atlanta campus and continue to work with the vendor on a resolution. Thus far there has been no loss of services, but the potential for service disruption is possible. We will continue to provide updates as more information becomes available.
Posted Oct 20, 2019 - 09:47 EDT
Identified
The Atlanta campus has experienced a power outage. Please be aware that services may be intermittent during this interruption. We will provide an update to the post as more information become available.
Posted Oct 19, 2019 - 22:19 EDT