Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

SSO Login Issues Reported

Incident Report for GSU Technology Systems

Resolved

Users should no longer see an error message when logging onto SSO login services.

Please submit a new incident to help@gsu.edu, help.gsu.edu or call 404-413-4357(HELP) to report if any error returns or continues.
Posted Aug 26, 2026 - 09:48 EDT

Monitoring

The SSO login outage has been resolved and IIT will continue to monitor the affected services, including:

PAWs
iCollege
Banner
Other websites that use the university’s Single Sign-On (SSO)

You should no longer see an error message when logging onto SSO login services.

Please submit a new incident to help@gsu.edu, help.gsu.edu or call 404-413-4357(HELP) to report if error returns or continues.
Posted Aug 25, 2026 - 11:59 EDT

Investigating

Instructional Innovation & Technology (IIT) is actively investigating an SSO login outage.

Affected services include:

PAWs
iCollege
Banner
Other websites that use the university’s Single Sign-On (SSO)

You may see: “Oops, we had trouble logging you in.”

Updates will be posted as they become available.
Posted Aug 25, 2026 - 10:40 EDT
This incident affected: ICollege, PAWS, GoSOLAR, and Student Information System (SIS).