Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Email Access Gateway Timeout Issue - Duo Multifactor

Incident Report for GSU Technology Systems

Monitoring

The issue affecting email authentication through Duo Security appears to be resolved.

Users should now be able to successfully initiate new login sessions for the following services:

Web email access (including web authentications)

Desktop and Mobile Microsoft Outlook

Microsoft Teams (when requiring a fresh login)

We will continue to monitor the environment to ensure stability, but at this time no further user impact is expected.

If you continue to experience issues, please contact the IT Service Desk at 404-413-4357(HELP) or email help@gsu.edu.
Posted Feb 23, 2026 - 15:07 EST

Investigating

We are currently investigating an issue affecting email authentication through Duo Security.

Some users may experience a 504 Gateway Timeout error when attempting a new email login session. At this time, the vendor’s status page does not indicate a widespread outage; however, a support ticket has been opened and we are actively working to determine the cause.

Impacted Services:

Web email access (including web authentications)

Desktop Outlook application

Mobile Outlook application

Teams (only impacted if needing a fresh login)

Users who are already logged into email services should not be impacted.

We will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Feb 23, 2026 - 10:00 EST
This incident affects: PantherMail (Student Email) and Office 365 (Fac/Staff Email).