Get email notifications whenever GSU Technology Systems creates, updates or resolves an incident.
Get text message notifications whenever GSU Technology Systems creates or resolves an incident.
Get webhook notifications whenever GSU Technology Systems creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 21:00 EDT
Scheduled
Instructional Innovation & Technology (IIT) will conduct firewall maintenance at the Atlanta and Perimeter Campus on Friday, March 21st, from 9:00 p.m. until 1:00 a.m. During this time, there may be brief interruptions to firewall services.
If you have any questions about this maintenance or need assistance, please contact the IIT Technology Service Desk at help@gsu.edu or 404-413-HELP (404-413-4357).
Posted Mar 19, 2025 - 10:44 EDT
This scheduled maintenance affected: Campus Network.