Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

GSU Network

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Jun 07, 2023 - 08:10 EDT

Update

Services to the network have been restored. We will continue to monitor. If you are still experiencing an issue, please email help@gsu.edu or contact the Technology Service Desk at 404-413-4357.
Posted May 05, 2023 - 13:21 EDT

Investigating

Instructional Innovation and Technology (IIT) is investigating intermittent issues being reported regarding the GSU network. More information will be provided as they become available.
Posted May 05, 2023 - 12:47 EDT
This incident affected: Campus Network.