Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
iCollege URL Issues
Incident Report for GSU Technology Systems
Monitoring
Georgia State University web sites have been restored, and icollege.gsu.edu is available at this time. IIT continues to monitor Georgia State web site performance at this time.
Posted Jul 20, 2020 - 16:44 EDT
Update
Using the url icollege.gsu.edu is returning an error due to the Georgia State University web site having errors.

Please use gastate.view.usg.edu to access iCollege at this time.
Posted Jul 20, 2020 - 14:39 EDT
Identified
Using the url icollege.gsu.edu is returning an error due to the Georgia State University web site having errors.

Please use gastate.view.usg.edu to access iCollege at this time.
Posted Jul 20, 2020 - 14:32 EDT
This incident affects: Brightspace/iCollege.