Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Reported Internet Issues Downtown Campus
Incident Report for GSU Technology Systems
Resolved
The Internet access issue has been resolved. If your technical issue is not resolved, then please contact IIT Technology Service Desk at 404-413-4357(HELP) or email help@gsu.edu to report your issue.
Posted 21 days ago. Jul 02, 2019 - 22:59 EDT
Monitoring
Internet access issue has been resolved by the service provider. IIT will continue to monitor.
Posted 22 days ago. Jul 01, 2019 - 22:21 EDT
Investigating
IIT is investigating reported internet access issues on the Downtown Campus and some limited Perimeter Campus service issues thru our service provider. More information will be provided as it comes available.
Posted 22 days ago. Jul 01, 2019 - 22:09 EDT