Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Decatur Campus: Network Outage

Incident Report for GSU Technology Systems

Resolved

If you continue to experience any issues please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Jun 05, 2025 - 07:48 EDT

Monitoring

Power has been restored and the Network is operational. We will continue to monitor. If you continue to experience any issues please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Jun 02, 2025 - 23:59 EDT

Identified

Due to a Georgia Power outage, the Decatur campus is currently experiencing a network disruption. We are actively monitoring the Georgia Power website for status updates.

At this time, no estimated restoration time has been provided.

We will share updates as new information becomes available.

Thank you for your patience
Posted Jun 02, 2025 - 21:18 EDT
This incident affected: Campus Network.