Get email notifications whenever GSU Technology Systems creates, updates or resolves an incident.
Get text message notifications whenever GSU Technology Systems creates or resolves an incident.
Get webhook notifications whenever GSU Technology Systems creates an incident, updates an incident, resolves an incident or changes a component status.
IIT has restored access to the student PantherMail portal. Please visit the link below for instructions on how to clear your browser cache. Once cleared, you should be able to access panthermail.gsu.edu.
If you continue to experience an issue, please email help@gsu.edu or contact 404-413-4357(HELP).
Posted Jun 02, 2023 - 15:40 EDT
Identified
Instructional Innovation and Technology (IIT) has been made aware of possible PantherMail access issues on Microsoft 365 Online apps. Users report panthermail.gsu.edu will not load to allow further authentication. IIT is currently working to restore this service.
Posted Jun 02, 2023 - 14:48 EDT
This incident affected: PantherMail (Student Email).