Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Dunwoody Campus (Power)

Incident Report for GSU Technology Systems

Resolved

The power outage at the Dunwoody Campus has been resolved, and services have been restored.
Posted Sep 03, 2026 - 19:58 EDT

Investigating

Instructional Innovation & Technology (IIT) has identified a power outage at the Dunwoody Campus. Updates will be provided as soon as more information becomes available.
Posted Sep 03, 2026 - 19:38 EDT
This incident affected: Campus Network.