Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Sparks Hall Classrooms: AV issue
Incident Report for GSU Technology Systems
Resolved
IIT was able to resolve the issues reported with Sparks Hall classroom AV equipment. Please contact IIT Technology Service Desk to report any additional concerns at 404-413-4357(HELP) or email help@gsu.edu.
Posted 23 days ago. Sep 24, 2019 - 08:29 EDT
Investigating
Instructional Innovation and Technology is investigating an issue with the Audio Visual equipment in the Sparks Hall Classrooms. For instructors teaching in the Sparks Hall classrooms today, please call 404-413-4321 to request technical assistance.
Posted 27 days ago. Sep 20, 2019 - 11:12 EDT