Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Office 365 (Fac/Staff Email) Issues Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) resolved the issue with Office 365 (Fac/Staff Email) security certificate. All Faculty/Staff should now be able to access email without an error. Please contact IIT Technology Service Desk at 404-413-4357(HELP) or email help@gsu.edu to report any additional service issues.
Posted Aug 02, 2019 - 10:24 EDT
Monitoring
Instructional Innovation and Technology (IIT) resolved the issue with Office 365 (Fac/Staff Email) security certificate. All Faculty/Staff should now be able to access email without an error. Our IIT team will continue to monitor this incident over the next 24 hours. Please contact IIT Technology Service Desk at 404-413-4357(HELP) or email help@gsu.edu to report any additional service issues.
Posted Jul 31, 2019 - 09:41 EDT
Identified
Instructional Innovation and Technology (IIT) is currently investigating and have identified the cause of the issue with Office 365 (Fac/Staff Email). It is safe to proceed and access our GSU Faculty/Staff email by choosing the ADVANCED option on the page. Additional information will be posted here when the issue is confirmed.
Posted Jul 31, 2019 - 08:36 EDT
This incident affected: Office 365 (Fac/Staff Email).