Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Network Issues - Atlanta Campus

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 17:12 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2026 - 11:40 EST

Investigating

Please be advised that the Network Engineering is investigating network issues that may be impacting applications. We will provide updates as soon as we have more information.

Potential Impacts:

PantherCard Access
Banner
Campus ID Password Self-Service
Posted Jan 30, 2026 - 11:04 EST
This incident affected: Campus Network, Server, and PantherCard.