Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Paws Access Issue
Incident Report for GSU Technology Systems
Resolved
This incident has been resolved.
Posted Sep 25, 2022 - 14:09 EDT
Investigating
Instructional Innovation & Technology (IIT) is currently investigating issues accessing Paws. End-Users may receive a blank page after selecting the login button on the Paws portal page. More information will be provided once available.
Posted Sep 21, 2022 - 07:23 EDT
This incident affected: PAWS.