Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Multiple Power Outages Affecting Buildings and Parking Decks

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 08:15 EDT

Monitoring

All buildings and parking decks are now back online.

Please report any new incidents to help.gsu.edu, help@gsu.edu or 404-413-4357(HELP).
Posted Mar 28, 2025 - 12:36 EDT

Investigating

We are currently experiencing multiple power outages affecting various buildings and parking decks; see below.

Piedmont Central
University Lofts
Sculpture Studio
Parking Decks S, M, N and K
Petit Science Center

Our team is actively investigating the issue in collaboration with the appropriate departments.
Posted Mar 28, 2025 - 09:55 EDT
This incident affected: Campus Network and Campus Wireless Network.