Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Campus ID and Duo Pages Inaccessible

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 15:36 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 10:56 EDT

Investigating

We are currently investigating issues affecting access to campusid.gsu.edu and the Self-Service DUO Bypass pages.

If you need immediate assistance, please contact the IIT Technology Service Desk at 404-413-4357 (HELP).

Thank you for your patience as we work to resolve the issue.
Posted Jul 27, 2026 - 10:49 EDT
This incident affected: CampusID.