Get email notifications whenever GSU Technology Systems creates, updates or resolves an incident.
Get text message notifications whenever GSU Technology Systems creates or resolves an incident.
Get webhook notifications whenever GSU Technology Systems creates an incident, updates an incident, resolves an incident or changes a component status.
Between approximately 3:00 a.m. and 5 p.m. on Monday, October 20, 2025, Brightspace was experiencing intermittent issues with multiple services due to an Amazon Web Services (AWS) outage.
Multiple services' functionality that were affected by the AWS outage has been restored, and USG's Information Technology Services (ITS) is currently monitoring.
In the event that you experience any further issues with accessing GSU applications, please submit a NEW incident to IIT Technology Service Desk to help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP)
Posted Oct 21, 2025 - 07:31 EDT
Update
Qualtrics and KnowBe4 learning modules may also experience technical issues due to the AWS outage.
Posted Oct 20, 2025 - 11:37 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:36 EDT
Update
USG's Information Technology Services (ITS) has confirmed that iCollege/Brightspace has been impacted by the Amazon Web Services (AWS) outage. As well as, the PAWs application is also affected by this outage.
Although services are improving, users may continue to experience some slowness or outages with iCollege and PAWs
Posted Oct 20, 2025 - 11:13 EDT
Identified
USG's Information Technology Services (ITS) has confirmed that iCollege/Brightspace has been impacted by the Amazon Web Services (AWS) outage. Although services are improving, users may continue to experience some slowness or outages. D2L is continuing to work to resolve this as quickly as possible.
Posted Oct 20, 2025 - 10:20 EDT
This incident affects: Brightspace/iCollege and PAWS.