Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Power Outage: 75 Piedmont-Citizens Trust Building (CTB)

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 14:17 EDT

Monitoring

Power has been restored to CTB, and all network services are now operational.
Posted Jul 20, 2026 - 09:34 EDT

Identified

A utility power outage is currently affecting 75 Piedmont (CTB).

As a result, ALL wired and wireless network connectivity, voice services, and card reader access are unavailable throughout the building.

Teams are aware of the outage and are working with the utility provider to restore power. Updates will be provided on status.gsu.edu as more information becomes available.
Posted Jul 20, 2026 - 06:56 EDT
This incident affected: Campus Network and Campus Wireless Network.