Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Kaltura Video Streaming Issues
Incident Report for GSU Technology Systems
Resolved
The vendor deployed a fix yesterday evening, and video streaming should be working normally at this time. If you do continue to see issues, please contact the Service Desk at help@gsu.edu.
Posted Sep 24, 2019 - 08:22 EDT
Identified
Kaltura has identified an error with video playback. Some videos are failing to load or will not play appropriately.

Kaltura is working on a resolution to this error at this time.
Posted Sep 23, 2019 - 12:18 EDT
This incident affected: Brightspace/iCollege.