Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

GSU Websites: Degraded Performance

Incident Report for GSU Technology Systems

Resolved

GSU websites performance issues are resolved.

Please report any new GSU website related issues to the Wordpress support team using the form below:

https://commkit.gsu.edu/support/
Posted Jun 13, 2025 - 07:46 EDT

Monitoring

GSU websites are in recovery mode and coming back online. We will continue to monitor this event over the next few hours.

Report any new GSU website related issues to the Wordpress support team using the form below:

https://commkit.gsu.edu/support/
Posted Jun 12, 2025 - 17:07 EDT

Identified

GSU is currently seeing degraded performance of our websites.

Administrators should pause working on the backend of the system until it is restored. Users will see this issue as it includes the delivery of Google Fonts and other resources.  

Cloudflare has a public notice up indicating the outage of their services.

Our support team will do their best to report any resolution or updates as they are available. Access, while slow and not fully styled, remains available.

https://www.cloudflarestatus.com/
Posted Jun 12, 2025 - 14:53 EDT
This incident affected: University Website.