Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Microsoft Teams
Incident Report for GSU Technology Systems
Resolved
The Microsoft Teams issue has been resolved. Please report any new Microsoft Teams related problems to help.gsu.edu, help@gsu.edu or call 404-413-4357(HELP).
Posted Jan 30, 2024 - 09:28 EST
Update
Some users may be experiencing multiple issues with their Microsoft Teams. Users may experience multiple issues with their Microsoft Teams, including but not limited to:

- Users logging in or unlocking their devices after some time may see missing messages
- Users may fail to load messages in channels and chats
- Users are unable to view or download their media (images, videos, audio, call recordings, code snippets)
- Some messages may experience delays being sent
- Sending and receiving read receipt notifications may be delayed

The issue is currently being investigated, and updates will be provided periodically.
Posted Jan 26, 2024 - 13:44 EST
Investigating
We're investigating an issue impacting multiple Microsoft Teams features. More information will be provided as it becomes available.
Posted Jan 26, 2024 - 13:18 EST
This incident affected: Office 365 (Fac/Staff Email).