Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Perimeter Campuses - Classroom Phone Issue
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved classroom phone issues at all Perimeter Campuses.

If you have any questions, please contact the IIT Technology Service Desk at help@gsu.edu or 404-413-HELP (404-413-4357) for assistance.
Posted Nov 12, 2019 - 15:33 EST
Investigating
Please be advised that IIT Telecom is aware and working aggressively with other IIT departments to resolve Classroom phone issues at all Perimeter Campuses. Some classrooms may experience no dial tone or see various error messages or possibly both problems.

More updates will be provided as they become available.

If you have any questions, please contact the IIT Technology Service Desk at help@gsu.edu or 404-413-HELP (404-413-4357) for assistance.
Posted Oct 25, 2019 - 18:23 EDT
This incident affected: Telephone System.