Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

GSU-Guest and Visitor Networks

Incident Report for GSU Technology Systems

Monitoring

A fix has been implemented by IIT and will now continue to monitor the results over the next 24 hours.

If you are still having an issue with these services, please open a new incident on help.gsu.edu, email help@gsu.edu or call 404-413-4357(HELP)
Posted May 28, 2025 - 09:17 EDT

Investigating

Instructional Innovation and Technology (IIT) is investigating connectivity issues affecting "GSU-Guest" and "Visitor" wireless networks. 

Please note that "GSU" wireless remains fully operational.

Additional updates will be shared as we continue to diagnose the issue and gather more information.
Posted May 27, 2025 - 11:57 EDT
This incident affects: Campus Network.