Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Clarkston Campus Network

Incident Report for GSU Technology Systems

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 09:02 EDT

Identified

The Clarkston Campus network is currently experiencing a disruption due to a power outage in the area. The power company is assessing the situation and will provide an ETA.
Posted Oct 08, 2025 - 17:46 EDT
This incident affects: Campus Network.