Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Kaltura Performance
Incident Report for GSU Technology Systems
Resolved
Kaltura has resolved the previously reported issues. Please contact help@gsu.edu if you do run into problems when using Kaltura.
Posted Apr 13, 2020 - 14:17 EDT
Investigating
Kaltura is currently investigating a problem with their upload services. Videos may take longer than normal to upload.
Posted Apr 13, 2020 - 13:42 EDT
This incident affected: Kaltura.