Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Down
Incident Report for GSU Technology Systems
Monitoring
A fix has been implemented. We will continue to monitor the operations of GSU sites. If you continue experiencing issues, please contact the Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Jul 20, 2020 - 16:40 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating an issue with the GSU website. They are working to rectify the issue. Updates will be posted as they become available. If you have questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Jul 20, 2020 - 14:40 EDT
This incident affects: University Website.