Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Websites Issue
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) have resolved issues reported about some computer users having trouble reaching websites and applications with “gsu.edu” web addresses from on and off campus. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted about 1 month ago. Jun 10, 2019 - 08:03 EDT
Monitoring
Instructional Innovation and Technology (IIT) have resolved issues reported about some computer users having trouble reaching websites and applications with “gsu.edu” web addresses from on and off campus. We will continue to monitor the status. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted about 2 months ago. Jun 04, 2019 - 15:32 EDT
Investigating
Instructional Innovation and Technology (IIT) is investigating reports that some computer users are having trouble reaching websites and applications with “gsu.edu” web addresses from on and off campus. Additional information will be posted as it becomes available.
Posted about 2 months ago. Jun 04, 2019 - 12:06 EDT
This incident affected: University Website.