Get email notifications whenever GSU Technology Systems creates, updates or resolves an incident.
Get text message notifications whenever GSU Technology Systems creates or resolves an incident.
Get webhook notifications whenever GSU Technology Systems creates an incident, updates an incident, resolves an incident or changes a component status.
An emergency maintenance has been completed and services should have returned to normal. We will continue to monitor the system over the next few hours.
Please report any new network connection issues to IIT Technology Service Desk at help@gsu.edu, help.gsu.edu or call 404-413-4357(HELP).
Posted Mar 24, 2025 - 15:57 EDT
Identified
Emergency maintenance will now occur to restore normal service. During this time, you may experience slow network connectivity. We anticipate the maintenance will take an hour or less to complete.
Posted Mar 24, 2025 - 14:33 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with the Campus Network and Wireless Network. Additional information will be posted here when the issue is confirmed.
Posted Mar 24, 2025 - 11:48 EDT
This incident affected: Campus Network and Campus Wireless Network.