Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Power Outage - Dunwoody Campus

Incident Report for GSU Technology Systems

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 08:10 EDT

Update

Power has been restored at Dunwoody Campus. We will continue to monitor the situation and provide additional updates if needed.
Posted Jul 09, 2026 - 17:59 EDT

Identified

Dunwoody Campus is experiencing a campus-wide power outage due to an issue with the utility provider. There is currently no estimated time for power restoration. Additional updates will be provided as they become available.
Posted Jul 09, 2026 - 17:58 EDT
This incident affected: Campus Network.