Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)

Newton Campus - Network Outage

Incident Report for GSU Technology Systems

Resolved

The Newton Campus network incident is resolved. Please submit a new incident to IIT Technology Service Desk at help@gsu.edu, help.gsu.edu or call 404-413-4357(help).
Posted Apr 21, 2026 - 21:28 EDT

Identified

The outage has been traced to a damaged fiber cable. Restoration is actively underway, and we will share updates, including estimated timelines, as they become available.
Posted Apr 21, 2026 - 16:06 EDT

Investigating

Newtown Campus is currently impacted by a network outage. IIT has initiated a priority escalation with our telecom partner and is actively managing the investigation and resolution process.
Posted Apr 21, 2026 - 14:48 EDT
This incident affected: Campus Network.