Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Perimeter Campus Network Issues Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved issues reported in regards to the Perimeter Campus Network. Please contact the IIT Technology Service Desk to report any additional concerns by either emailing help@gsu.edu or calling 404-413-4357(HELP).
Posted 23 days ago. Sep 29, 2017 - 08:31 EDT
Update
Our team is currently still monitoring updates implemented by the Board of Regents. Please contact IIT Technology Service Desk to report any additional concerns by either emailing help@gsu.edu or calling 404-413-4357(HELP).
Posted about 1 month ago. Sep 22, 2017 - 13:05 EDT
Update
Updates have been successfully implemented. Our team will continue to monitor these changes over the next two business days. Please contact IIT Technology Service Desk to report any additional concerns by either emailing help@gsu.edu or calling 404-413-4357(help)
Posted about 1 month ago. Sep 18, 2017 - 07:25 EDT
Monitoring
Updates have been successfully implemented. Our team will continue to monitor these changes over the next two business days. Please contact IIT Technology Service Desk to report any additional concerns by either emailing help@gsu.edu or calling 404-413-4357(help).
Posted about 1 month ago. Sep 16, 2017 - 11:50 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of slow wired internet connectivity on Perimeter Campus Network. Additional information will be posted here when the issue is confirmed.
Posted about 1 month ago. Sep 15, 2017 - 09:31 EDT