Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Clarkston Campus Power Outage
Incident Report for GSU Technology Systems
Resolved
GA Power had restored power to Clarkston Campus. All network equipment is up and operational. If you are still having issues please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Sep 25, 2017 - 11:35 EDT
Identified
There is currently a power outage that is affecting the entire Clarkston campus. GA Power is unable to provide an ETA at this time. Further details and updates will be posted here when they become available.
Posted Sep 25, 2017 - 09:43 EDT