Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Telephone Service Interruption on Downtown Campus
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has restored functionality to telephone service. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Jun 17, 2018 - 21:10 EDT
Monitoring
Instructional Innovation and Technology (IIT) has restored functionality to telephone service. We will continue to monitor the system to ensure full functionality. We will continue to provide updates.
Posted Jun 16, 2018 - 17:19 EDT
Identified
Instructional Innovation and Technology (IIT) has identified an issue with our provider experiencing an outage in our area. We will continue to provide updates as quickly as they are received.
Posted Jun 16, 2018 - 16:11 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating issues with telephone service interruption on the Downtown campus. More updates will be provided as they are made available. If you have any questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Jun 16, 2018 - 13:30 EDT
This incident affected: Telephone System.