Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
High Call Volume
Incident Report for GSU Technology Systems
Resolved
There have been no new reports related to this incident. Please contact IIT Technology Service Desk by phone at 404-413-4357(HELP) or email help@gsu.edu to report any additional questions or concerns.
Posted 25 days ago. Sep 01, 2017 - 07:32 EDT
Monitoring
The University is currently experiencing extremely high call volume this morning and some users are reporting they are receiving busy signals. IIT is currently monitoring the situation and adjusting numbers, as appropriate.

Additional information will be posted here when as needed.

Thanks!
Posted about 2 months ago. Aug 08, 2017 - 13:49 EDT