Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Telephone System Issue Reported
Incident Report for GSU Technology Systems
Resolved
The call volume to GSU phone line system is back to normal. All users should be able to successfully complete outbound and inbound calls to GSU 404-413-xxxx. Please contact IS&T Help Center to report any additional problems at 404-413-4357(HELP) or email help@gsu.edu.
Posted Aug 25, 2015 - 11:06 EDT
Monitoring
At this time IS&T is monitoring the GSU phone system lines. Effective Tuesday August 18, all users have been able to make outbound calls and nearly all inbound calls to GSU 404-413-xxxx numbers have been able to successfully complete. For the remainder of the week, IS&T will continue to monitor the call volume during this peak time of year.
Posted Aug 19, 2015 - 16:38 EDT
Investigating
At this time, GSU phone lines (404-413-XXXX numbers) are experiencing a high influx of calls. Intermittent calls from external numbers are not completing to GSU numbers and GSU users are unable to make external calls on an intermittent basis and receiving a busy tone.

Additional information will be posted here when the issue is confirmed.

We will monitor all lines until call volume has decreased.
Posted Aug 17, 2015 - 15:45 EDT