Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Voicemail Issues on Perimeter Campuses
Incident Report for GSU Technology Systems
Resolved
voice mail issue at Perimeter Campus has been resolved
Posted Apr 20, 2018 - 00:07 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating issues with voicemail at Perimeter campuses. We will provide more updates when available. If you have any questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Apr 19, 2018 - 10:55 EDT