Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
IIT is investigating issue with Campus Web gsu.edu
Incident Report for GSU Technology Systems
Resolved
Maintenance is complete
Posted Aug 07, 2017 - 21:57 EDT
Identified
Maintenance is nearly complete
Posted Aug 07, 2017 - 21:46 EDT
Investigating
IIT is investigating an issue with the campus web site gsu.edu
Check here for updates
Posted Aug 07, 2017 - 21:24 EDT