Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
100 Auburn Building Network Outage
Incident Report for GSU Technology Systems
Resolved
100 Auburn network and phone service are fully recovered and restored. If you are still experiencing issues, please contact the Help Desk at (404) 413-4357.
Posted 2 months ago. Aug 09, 2017 - 13:14 EDT
Investigating
Currently, we are experiencing a network outage at 100 Auburn building. Network team is investigating the cause of this issue.
Posted 2 months ago. Aug 09, 2017 - 11:05 EDT