Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
(Faculty/Staff) Office 365 Outlook Web App Issue
Incident Report for GSU Technology Systems
Resolved
IIT resolved the Faculty/Staff Outlook Web App error. Faculty/Staff please refresh your internet browsers to access your Faculty/Staff email accounts online. Contact IIT Technology Service Desk by phone 404-413-4357(HELP) or email help@gsu.edu to report any additional problems or concerns regarding email.
Posted Feb 13, 2017 - 08:56 EST
Investigating
Instructional Innovation and Technology is currently investigating reports of Faculty/Staff unable to access Outlook Web App online. Affected users are receiving a Reference Number error message on their browser. As a work around, please use your Microsoft Outlook Client to access emails until web app issue is resolved. Continue to check here for additional updates.
Posted Feb 13, 2017 - 07:53 EST