Get email notifications whenever GSU Technology Systems creates, updates or resolves an incident.
Get text message notifications whenever GSU Technology Systems creates or resolves an incident.
Get webhook notifications whenever GSU Technology Systems creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2026 - 23:00 EDT
Scheduled
USG PeachNet will be performing scheduled switch upgrades affecting Georgia State University’s Dunwoody and Alpharetta campuses.
Maintenance Window: Tuesday, May 12, 2026, at 11:00 p.m. through Wednesday, May 13, 2026, at 7:00 a.m.
Expected Impact: A brief disruption to network services is expected during the maintenance window. Service interruptions are anticipated to last approximately five minutes per campus.
Affected Locations:
Georgia State University – Dunwoody Campus (GPCDUN) Georgia State University – Alpharetta Campus (GSUALP)
Posted May 11, 2026 - 18:48 EDT
This scheduled maintenance affected: Campus Network.