Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Phone Service Maintenance
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology has completed maintenance to the Perimeter Campus telephone system after reports of intermittent telephone service interruptions were reported across multiple Perimeter campuses. Telephone service is available across campuses. We will continue to monitor services. Please contact the IIT Technology Service Desk at 404-413-4357, or email help@gsu.edu if you continue to experience issues.
Posted Nov 28, 2017 - 12:25 EST
Update
Instructional Innovation and Technology has completed maintenance to the Perimeter Campus telephone system after reports of intermittent telephone service interruptions were reported across multiple Perimeter campuses today, Monday, November 27. Telephone service is available across campuses. We will continue to monitor services. Please contact the IIT Technology Service Desk at 404-413-4357, or email help@gsu.edu if you continue to experience issues.
Posted Nov 27, 2017 - 16:31 EST
Monitoring
Instructional Innovation and Technology (IIT) has completed emergency phone maintenance and services have been restored. We will continue to monitor to ensure stability. If you continue to experience issues, please contact the IIT Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Nov 27, 2017 - 12:34 EST
Identified
Instructional Innovation and Technology (IIT) is aware of issues with phone services on Perimeter campuses, and will be performing emergency maintenance to mitigate this problem. You may experience intermittent phone issues that may last up to ten minutes.. The IIT Service Desk will be impacted during this time-frame. If you have questions or concerns, please email help@gsu.edu. More information will be posted when maintenance is completed.
Posted Nov 27, 2017 - 10:32 EST