Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
IIT resolved the issues reported with GSU Websites. Please report any additional issues to IIT Service Desk at 404-413-4357(HELP) or email help@gsu.edu
Posted 3 months ago. May 17, 2017 - 07:51 EDT
Monitoring
IIT identified and resolved the issues reported with GSU Websites, but will continue to monitor reports over the next couple of hours. Please report any additional issues to IIT Service Desk at 404-413-4357(HELP) or email help@gsu.edu.
Posted 3 months ago. May 16, 2017 - 12:36 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with GSU Websites. Additional information will be posted here when the issue is confirmed.
Posted 3 months ago. May 16, 2017 - 12:03 EDT